Skip to main content
Older versions of Internet Explorer will not support certain site features. Chrome, Safari, Firefox, and Edge will provide the best experience.
Upgrading RabbitMQ and Erlang
This article provides instructions for upgrading to RabbitMQ 3.8.3 and Erlang OTP 22.
Installing Spok Mobile Services
These instructions describe how to install Spok Mobile services using the Care Connect Suite Installer.
Installing the Spok Mobile Message Monitoring Service
This article describes how to deploy the Spok Mobile Hosted Message Monitoring Service components.
Converting the PFX Certificate to PEM Certificates for the Spok Notification Framework (for CCS 1.9.2.160)
Three PEM certificates are required in order to secure the Spok Notification Framework via TLS. If your customer site will be using the Spok Notification Framework to support non-GCM (Google Cloud Messaging) Android Devices, a Spok PSG professional will perform the conversion process, as described in this article.
Converting the PFX Certificate to PEM Certificates for the Spok Notification Framework (for CCS 1.9.3.x)
This procedure must be completed following the installation of Spok Mobile at customer sites where the Spok Notification Framework will be used to support non-GCM Android devices. This procedure is completed by a Spok PSG professional to convert PFX format certificates to the three PEM format certificates needed to make the framework secure via TLS.
Configuring Spok Mobile Settings and Devices
These pages contain the steps for configuring Spok Mobile 4.6 settings and devices.
Optional Spok Mobile Configurations
This topic describes how to set up optional configurations in addition to the standard, required configurations which must be done for every Spok Mobile implementation.
Post-Implementation Considerations
These articles describe some additional considerations after you have implemented Spok Mobile.
Resetting IIS on the Spok Mobile Server
This topic describes how to reset IIS on the Spok Mobie Server.

 

Spok

Upgrading RabbitMQ and Erlang

This article provides instructions for upgrading to RabbitMQ 3.8.3 and Erlang OTP 22.

 

IMPORTANT: Prior to running the Spok Care Connect 1.9 Server installer, verify the RabbitMQ version on each of the servers. If RabbitMQ 3.8.3 is installed, continue to Installing Spok Mobile Services. If RabbitMQ 3.7.0 is installed, both RabbitMQ and Erlang must be manually uninstalled. The next release of the Spok Care Connect 1.9 Server installer will automatically install RabbitMQ 3.8.3 and Erlang OTP 22, and manually uninstalling will not be necessary. For now, see the instructions below.

Spok Care Connect 1.9.3.72 or earlier installs RabbitMQ 3.7.0 and Erlang OTP 20. When running the current version of the Spok Care Connect 1.9 installer, RabbitMQ does not upgrade from version 3.7.0 to version 3.8.3. Therefore, RabbitMQ 3.7.0 must be manually uninstalled before running the Spok Care Connect 1.9 Server installer to perform an upgrade.

Uninstalling RabbitMQ and Erlang

  1. Navigate to Control Panel > Programs > Programs and Features.
  2. Click on RabbitMQ Server 3.7.0, then click Uninstall.
  3. Wait until RabbitMQ Server 3.7.0 is uninstalled, then click on Erlang OTP 20(9.1).
  4. Click Uninstall.

Deleting the Erlang Folder

This must be done on each server.

  1. Open Task Manager, then click Details.
  2. Click on epmd.exe, then click End Task.

    You must do this to delete the Erlang folder.

  3. Navigate to C:\Program Files, then right-click the erl9.1 folder.
  4. Click Delete.

    If Windows does not allow you to delete the erl9.1 folder and displays a folder in use error message, restart the system and try to delete the erl9.1 folder again.