Skip to main content
Older versions of Internet Explorer will not support certain site features. Chrome, Safari, Firefox, and Edge will provide the best experience.
Resources
Spok

End of Browser Developer Support for TLS 1.0 and 1.1

The major browser developers, Google, Microsoft, and Mozilla, have recently announced that they will end support of TLS versions 1.0 and 1.1 in early 2020.  This will leave only the TLS versions 1.2 and above as the versions supported by the browser developers.  When browsers developers end TLS 1.0 and 1.1 support Spok customers may no longer be able to access secure Spok websites, such as those provided by Smart Web, Spok Web, and WebXchange.

With the Care Connect 1.9 release Spok fully supports TLS 1.2 across all platforms, and we will investigate TLS 1.3 support when it becomes available from the operating system vendors.  Those customers on previous Care Connect system versions are strongly encouraged to contact your Spok sales representative to ask about upgrading to Care Connect 1.9.

 

Related Defects:

N/A

 


KB45378